<!DOCTYPE html> <!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!--><html lang="en-US" class="no-js"> <!--<![endif]--><head><meta charset="UTF-8" /><meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, user-scalable=0"><meta name="theme-color" content="#790d0d" /><link rel="profile" href="https://gmpg.org/xfn/11" /> <script type="text/javascript">if (/Android|webOS|iPhone|iPad|iPod|BlackBerry|IEMobile|Opera Mini/i.test(navigator.userAgent)) {
                var originalAddEventListener = EventTarget.prototype.addEventListener,
                    oldWidth = window.innerWidth;

                EventTarget.prototype.addEventListener = function (eventName, eventHandler, useCapture) {
                    if (eventName === "resize") {
                        originalAddEventListener.call(this, eventName, function (event) {
                            if (oldWidth === window.innerWidth) {
                                return;
                            }
                            else if (oldWidth !== window.innerWidth) {
                                oldWidth = window.innerWidth;
                            }
                            if (eventHandler.handleEvent) {
                                eventHandler.handleEvent.call(this, event);
                            }
                            else {
                                eventHandler.call(this, event);
                            };
                        }, useCapture);
                    }
                    else {
                        originalAddEventListener.call(this, eventName, eventHandler, useCapture);
                    };
                };
            };</script> <title>2021 NBA Draft: Winners and Losers - NBADraft.net</title> <script>// NEW -Create a script element to load Blockthrough script
var btScript = document.createElement('script');


// Update src based on link given to you by your PS manager
btScript.src = '//btloader.com/tag?o=5759505104109568&upapi=true';


// Insert script in the head
document.head.appendChild(btScript);</script> <meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://www.nbadraft.net/2021-nba-draft-winners-and-losers/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="2021 NBA Draft: Winners and Losers - NBADraft.net" /><meta property="og:description" content="Winner: Detroit Pistons Detroit was a winner on June 22nd, when the ping pong balls decided they would have the incredible fortune of drafting . The 6’8 point guard was a consensus first-team All-American, the Big 12 Freshman of the Year and the Big 12 Player of the Year. After averaging over 20 points, six&hellip;" /><meta property="og:url" content="https://www.nbadraft.net/2021-nba-draft-winners-and-losers/" /><meta property="og:site_name" content="NBADraft.net" /><meta property="article:publisher" content="https://www.facebook.com/nbadraft.net/" /><meta property="article:section" content="NCAA" /><meta property="article:published_time" content="2021-08-02T05:23:41+00:00" /><meta property="article:modified_time" content="2021-08-02T08:18:02+00:00" /><meta property="og:updated_time" content="2021-08-02T08:18:02+00:00" /><meta property="og:image" content="https://www.nbadraft.net/wp-content/uploads/2021/08/21draftclass01.jpg" /><meta property="og:image:secure_url" content="https://www.nbadraft.net/wp-content/uploads/2021/08/21draftclass01.jpg" /><meta property="og:image:width" content="700" /><meta property="og:image:height" content="394" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="Winner: Detroit Pistons Detroit was a winner on June 22nd, when the ping pong balls decided they would have the incredible fortune of drafting . The 6’8 point guard was a consensus first-team All-American, the Big 12 Freshman of the Year and the Big 12 Player of the Year. After averaging over 20 points, six&hellip;" /><meta name="twitter:title" content="2021 NBA Draft: Winners and Losers - NBADraft.net" /><meta name="twitter:site" content="@nbadraftnet" /><meta name="twitter:image" content="https://www.nbadraft.net/wp-content/uploads/2021/08/21draftclass01.jpg" /><meta name="twitter:creator" content="@nbadraftnet" /> <script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.nbadraft.net/#organization","name":"NBADraft.net","url":"https://www.nbadraft.net/","sameAs":["https://www.facebook.com/nbadraft.net/","https://twitter.com/nbadraftnet"],"logo":{"@type":"ImageObject","@id":"https://www.nbadraft.net/#logo","url":"https://www.nbadraft.net/wp-content/uploads/2019/05/nbadraft-logo-ret.jpg","width":554,"height":180,"caption":"NBADraft.net"},"image":{"@id":"https://www.nbadraft.net/#logo"}},{"@type":"WebSite","@id":"https://www.nbadraft.net/#website","url":"https://www.nbadraft.net/","name":"NBADraft.net","publisher":{"@id":"https://www.nbadraft.net/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://www.nbadraft.net/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://www.nbadraft.net/2021-nba-draft-winners-and-losers/#primaryimage","url":"https://www.nbadraft.net/wp-content/uploads/2021/08/21draftclass01.jpg","width":700,"height":394},{"@type":"WebPage","@id":"https://www.nbadraft.net/2021-nba-draft-winners-and-losers/#webpage","url":"https://www.nbadraft.net/2021-nba-draft-winners-and-losers/","inLanguage":"en-US","name":"2021 NBA Draft: Winners and Losers - NBADraft.net","isPartOf":{"@id":"https://www.nbadraft.net/#website"},"primaryImageOfPage":{"@id":"https://www.nbadraft.net/2021-nba-draft-winners-and-losers/#primaryimage"},"datePublished":"2021-08-02T05:23:41+00:00","dateModified":"2021-08-02T08:18:02+00:00"},{"@type":"Article","@id":"https://www.nbadraft.net/2021-nba-draft-winners-and-losers/#article","isPartOf":{"@id":"https://www.nbadraft.net/2021-nba-draft-winners-and-losers/#webpage"},"author":{"@id":"https://www.nbadraft.net/#/schema/person/a646fd060367e6a4438319fb81f69ce2"},"headline":"2021 NBA Draft: Winners and Losers","datePublished":"2021-08-02T05:23:41+00:00","dateModified":"2021-08-02T08:18:02+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://www.nbadraft.net/2021-nba-draft-winners-and-losers/#webpage"},"publisher":{"@id":"https://www.nbadraft.net/#organization"},"image":{"@id":"https://www.nbadraft.net/2021-nba-draft-winners-and-losers/#primaryimage"},"articleSection":"NCAA"},{"@type":["Person"],"@id":"https://www.nbadraft.net/#/schema/person/a646fd060367e6a4438319fb81f69ce2","name":"Michael Hopp","image":{"@type":"ImageObject","@id":"https://www.nbadraft.net/#authorlogo","url":"https://secure.gravatar.com/avatar/9775127f822f6170bb733c118107dd9c?s=96&d=mm&r=g","caption":"Michael Hopp"},"sameAs":[]}]}</script> <link rel='dns-prefetch' href='//ws.sharethis.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="NBADraft.net &raquo; Feed" href="https://www.nbadraft.net/feed/" /><link rel="alternate" type="application/rss+xml" title="NBADraft.net &raquo; Comments Feed" href="https://www.nbadraft.net/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="NBADraft.net &raquo; 2021 NBA Draft: Winners and Losers Comments Feed" href="https://www.nbadraft.net/2021-nba-draft-winners-and-losers/feed/" /> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.nbadraft.net\/wp-includes\/js\/wp-emoji-release.min.js?ver=bba49859d2fa3ea8fa1f079d3eeafc8d"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])?!1:!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);</script> <style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important}</style><link rel='stylesheet' id='lrm-modal-css' href='https://www.nbadraft.net/wp-content/plugins/ajax-login-and-registration-modal-popup/assets/lrm-core-compiled.css?ver=55' type='text/css' media='all' /><link rel='stylesheet' id='lrm-fonts-css' href='https://www.nbadraft.net/wp-content/plugins/ajax-login-and-registration-modal-popup/assets/fonts.css?ver=55' type='text/css' media='all' /><link rel='stylesheet' id='lrm-modal-skin-css' href='https://www.nbadraft.net/wp-content/plugins/ajax-login-and-registration-modal-popup/skins/default/skin.css?ver=55' type='text/css' media='all' /><link rel='stylesheet' id='wp-block-library-css' href='https://www.nbadraft.net/wp-includes/css/dist/block-library/style.min.css?ver=bba49859d2fa3ea8fa1f079d3eeafc8d' type='text/css' media='all' /><link rel='stylesheet' id='wp-block-library-theme-css' href='https://www.nbadraft.net/wp-includes/css/dist/block-library/theme.min.css?ver=bba49859d2fa3ea8fa1f079d3eeafc8d' type='text/css' media='all' /><link rel='stylesheet' id='bbp-default-css' href='https://www.nbadraft.net/wp-content/plugins/bbpress/templates/default/css/bbpress.css?ver=2.5.14-6684' type='text/css' media='screen' /><link rel='stylesheet' id='wpcdt-public-css-css' href='https://www.nbadraft.net/wp-content/plugins/countdown-timer-ultimate/assets/css/wpcdt-timecircles.css?ver=1.2.3' type='text/css' media='all' /><link rel='stylesheet' id='sof-home-hero-css' href='https://www.nbadraft.net/wp-content/plugins/sof-nba-home-hero/css/sof-home-hero.css?ver=1627965426' type='text/css' media='all' /><link rel='stylesheet' id='wp-show-posts-css' href='https://www.nbadraft.net/wp-content/plugins/wp-show-posts/css/wp-show-posts-min.css?ver=1.1.3' type='text/css' media='all' /><link rel='stylesheet' id='wp-ulike-css' href='https://www.nbadraft.net/wp-content/plugins/wp-ulike/assets/css/wp-ulike.min.css?ver=3.6.2' type='text/css' media='all' /><style id='wp-ulike-inline-css' type='text/css'>.wp_ulike_btn.wp_ulike_put_image:after{background-image:url(https://www.nbadraft.net/wp-content/uploads/2019/08/like.png)!important}.wp_ulike_btn.wp_ulike_put_image.image-unlike:after{background-image:url(https://www.nbadraft.net/wp-content/uploads/2019/08/unlike.png)!important;filter:none}</style><link rel='stylesheet' id='bsp-css' href='https://www.nbadraft.net/wp-content/plugins/bbp-style-pack/css/bspstyle.css?ver=4.3.2' type='text/css' media='screen' /><link rel='stylesheet' id='dashicons-css' href='https://www.nbadraft.net/wp-includes/css/dashicons.min.css?ver=bba49859d2fa3ea8fa1f079d3eeafc8d' type='text/css' media='all' /><link rel='stylesheet' id='dt_the7_child-main-css-css' href='https://www.nbadraft.net/wp-content/themes/dt-the7-child/css/main.css?ver=1627965426' type='text/css' media='all' /><link rel='stylesheet' id='the7-Defaults-css' href='https://www.nbadraft.net/wp-content/uploads/smile_fonts/Defaults/Defaults.css?ver=bba49859d2fa3ea8fa1f079d3eeafc8d' type='text/css' media='all' /><link rel='stylesheet' id='mycred-front-css' href='https://www.nbadraft.net/wp-content/plugins/mycred/assets/css/mycred-front.css?ver=1.8.6' type='text/css' media='all' /><link rel='stylesheet' id='tablepress-responsive-tables-css' href='https://www.nbadraft.net/wp-content/plugins/tablepress-responsive-tables/css/responsive.dataTables.min.css?ver=1.5' type='text/css' media='all' /><link rel='stylesheet' id='tablepress-default-css' href='https://www.nbadraft.net/wp-content/plugins/tablepress/css/default.min.css?ver=1.9.2' type='text/css' media='all' /><link rel='stylesheet' id='dt-web-fonts-css' href='//fonts.googleapis.com/css?family=Roboto%3A400%2C500%2C600%2C700%7CMontserrat%3A400%2C500%2C600%2C700%7CRoboto+Condensed%3A400%2C600%2C700&#038;ver=7.8.1' type='text/css' media='all' /><link rel='stylesheet' id='dt-main-css' href='https://www.nbadraft.net/wp-content/themes/dt-the7/css/main.min.css?ver=7.8.1' type='text/css' media='all' /><link rel='stylesheet' id='the7-font-css' href='https://www.nbadraft.net/wp-content/themes/dt-the7/fonts/icomoon-the7-font/icomoon-the7-font.min.css?ver=7.8.1' type='text/css' media='all' /><link rel='stylesheet' id='the7-awesome-fonts-css' href='https://www.nbadraft.net/wp-content/themes/dt-the7/fonts/FontAwesome/css/all.min.css?ver=7.8.1' type='text/css' media='all' /><link rel='stylesheet' id='the7-awesome-fonts-back-css' href='https://www.nbadraft.net/wp-content/themes/dt-the7/fonts/FontAwesome/back-compat.min.css?ver=7.8.1' type='text/css' media='all' /><link rel='stylesheet' id='dt-fontello-css' href='https://www.nbadraft.net/wp-content/themes/dt-the7/fonts/fontello/css/fontello.min.css?ver=7.8.1' type='text/css' media='all' /><link rel='stylesheet' id='dt-custom-css' href='https://www.nbadraft.net/wp-content/uploads/the7-css/custom.css?ver=46a556ed7815' type='text/css' media='all' /><link rel='stylesheet' id='dt-media-css' href='https://www.nbadraft.net/wp-content/uploads/the7-css/media.css?ver=46a556ed7815' type='text/css' media='all' /><link rel='stylesheet' id='the7-mega-menu-css' href='https://www.nbadraft.net/wp-content/uploads/the7-css/mega-menu.css?ver=46a556ed7815' type='text/css' media='all' /><link rel='stylesheet' id='bb-press.less-css' href='https://www.nbadraft.net/wp-content/uploads/the7-css/compatibility/bb-press.css?ver=46a556ed7815' type='text/css' media='all' /><link rel='stylesheet' id='style-css' href='https://www.nbadraft.net/wp-content/themes/dt-the7-child/style.css?ver=7.8.1' type='text/css' media='all' /> <!--[if !IE]><!--><link rel='stylesheet' id='tablepress-responsive-tables-flip-css' href='https://www.nbadraft.net/wp-content/plugins/tablepress-responsive-tables/css/tablepress-responsive-flip.min.css?ver=1.5' type='text/css' media='all' /> <!--<![endif]--> <script type='text/javascript' src='https://www.nbadraft.net/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script> <script type='text/javascript' src='https://www.nbadraft.net/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script> <script type='text/javascript'>/* <![CDATA[ */ var playerSearch = {"ajaxurl":"https:\/\/www.nbadraft.net\/wp-admin\/admin-ajax.php"}; /* ]]> */</script> <script type='text/javascript' src='https://www.nbadraft.net/wp-content/plugins/nba_player_search/player_search.js?ver=1.62'></script> <script type='text/javascript' src='https://www.nbadraft.net/wp-content/plugins/sof-tablepress/js/sof-tablepress.js?ver=bba49859d2fa3ea8fa1f079d3eeafc8d'></script> <script id='st_insights_js' type='text/javascript' src='https://ws.sharethis.com/button/st_insights.js?publisher=eba0f3ba-f9ab-408c-bc68-c28af5afe749&#038;product=feather'></script> <script type='text/javascript'>/* <![CDATA[ */ var dtLocal = {"themeUrl":"https:\/\/www.nbadraft.net\/wp-content\/themes\/dt-the7","passText":"To view this protected post, enter the password below:","moreButtonText":{"loading":"Loading...","loadMore":"Load more"},"postID":"1251371","ajaxurl":"https:\/\/www.nbadraft.net\/wp-admin\/admin-ajax.php","REST":{"baseUrl":"https:\/\/www.nbadraft.net\/wp-json\/the7\/v1","endpoints":{"sendMail":"\/send-mail"}},"contactMessages":{"required":"One or more fields have an error. Please check and try again.","terms":"Please accept the privacy policy.","fillTheCaptchaError":"Please, fill the captcha."},"captchaSiteKey":"","ajaxNonce":"29f3f380d3","pageData":"","themeSettings":{"smoothScroll":"off","lazyLoading":false,"accentColor":{"mode":"solid","color":"#790d0d"},"desktopHeader":{"height":45},"floatingHeader":{"showAfter":140,"showMenu":true,"height":60,"logo":{"showLogo":true,"html":"<img class=\" preload-me\" src=\"https:\/\/www.nbadraft.net\/wp-content\/uploads\/2019\/05\/nbadraft-logo.png\" srcset=\"https:\/\/www.nbadraft.net\/wp-content\/uploads\/2019\/05\/nbadraft-logo.png 275w, https:\/\/www.nbadraft.net\/wp-content\/uploads\/2019\/05\/nbadraft-logo2-ret.png 542w\" width=\"275\" height=\"31\"   sizes=\"275px\" alt=\"NBADraft.net\" \/>","url":"https:\/\/www.nbadraft.net\/"}},"topLine":{"floatingTopLine":{"logo":{"showLogo":false,"html":""}}},"mobileHeader":{"firstSwitchPoint":1177,"secondSwitchPoint":778,"firstSwitchPointHeight":80,"secondSwitchPointHeight":60},"stickyMobileHeaderFirstSwitch":{"logo":{"html":"<img class=\" preload-me\" src=\"https:\/\/www.nbadraft.net\/wp-content\/uploads\/2019\/05\/nbadraft-logo.png\" srcset=\"https:\/\/www.nbadraft.net\/wp-content\/uploads\/2019\/05\/nbadraft-logo.png 275w, https:\/\/www.nbadraft.net\/wp-content\/uploads\/2019\/05\/nbadraft-logo2-ret.png 542w\" width=\"275\" height=\"31\"   sizes=\"275px\" alt=\"NBADraft.net\" \/>"}},"stickyMobileHeaderSecondSwitch":{"logo":{"html":"<img class=\" preload-me\" src=\"https:\/\/www.nbadraft.net\/wp-content\/uploads\/2019\/05\/nbadraft-logo.png\" srcset=\"https:\/\/www.nbadraft.net\/wp-content\/uploads\/2019\/05\/nbadraft-logo.png 275w, https:\/\/www.nbadraft.net\/wp-content\/uploads\/2019\/05\/nbadraft-logo2-ret.png 542w\" width=\"275\" height=\"31\"   sizes=\"275px\" alt=\"NBADraft.net\" \/>"}},"content":{"textColor":"#222222","headerColor":"#222222"},"sidebar":{"switchPoint":990},"boxedWidth":"1340px","stripes":{"stripe1":{"textColor":"#787d85","headerColor":"#3b3f4a"},"stripe2":{"textColor":"#8b9199","headerColor":"#ffffff"},"stripe3":{"textColor":"#ffffff","headerColor":"#ffffff"}}},"VCMobileScreenWidth":"768"};
var dtShare = {"shareButtonText":{"facebook":"Share on Facebook","twitter":"Tweet","pinterest":"Pin it","linkedin":"Share on Linkedin","whatsapp":"Share on Whatsapp"},"overlayOpacity":"85"}; /* ]]> */</script> <script type='text/javascript' src='https://www.nbadraft.net/wp-content/themes/dt-the7/js/above-the-fold.min.js?ver=7.8.1'></script> <link rel='https://api.w.org/' href='https://www.nbadraft.net/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.nbadraft.net/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.nbadraft.net/wp-includes/wlwmanifest.xml" /><link rel='shortlink' href='https://www.nbadraft.net/?p=1251371' /><link rel="alternate" type="application/json+oembed" href="https://www.nbadraft.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.nbadraft.net%2F2021-nba-draft-winners-and-losers%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.nbadraft.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.nbadraft.net%2F2021-nba-draft-winners-and-losers%2F&#038;format=xml" /> <script type="text/javascript">/* <![CDATA[ */ //<![CDATA[
  function external_links_in_new_windows_loop() {
    if (!document.links) {
      document.links = document.getElementsByTagName('a');
    }
    var change_link = false;
    var force = '';
    var ignore = '';

    for (var t=0; t<document.links.length; t++) {
      var all_links = document.links[t];
      change_link = false;
      
      if(document.links[t].hasAttribute('onClick') == false) {
        // forced if the address starts with http (or also https), but does not link to the current domain
        if(all_links.href.search(/^http/) != -1 && all_links.href.search('www.nbadraft.net') == -1 && all_links.href.search(/^#/) == -1) {
          // console.log('Changed ' + all_links.href);
          change_link = true;
        }
          
        if(force != '' && all_links.href.search(force) != -1) {
          // forced
          // console.log('force ' + all_links.href);
          change_link = true;
        }
        
        if(ignore != '' && all_links.href.search(ignore) != -1) {
          // console.log('ignore ' + all_links.href);
          // ignored
          change_link = false;
        }

        if(change_link == true) {
          // console.log('Changed ' + all_links.href);
          document.links[t].setAttribute('onClick', 'javascript:window.open(\''+all_links.href+'\'); return false;');
          document.links[t].removeAttribute('target');
        }
      }
    }
  }
  
  // Load
  function external_links_in_new_windows_load(func)
  {  
    var oldonload = window.onload;
    if (typeof window.onload != 'function'){
      window.onload = func;
    } else {
      window.onload = function(){
        oldonload();
        func();
      }
    }
  }

  external_links_in_new_windows_load(external_links_in_new_windows_loop);
  //]]> /* ]]> */</script> <link rel="pingback" href="https://www.nbadraft.net/xmlrpc.php"><style type="text/css"></style><style type="text/css">.synved-social-resolution-single{display:inline-block}.synved-social-resolution-normal{display:inline-block}.synved-social-resolution-hidef{display:none}@media only screen and (min--moz-device-pixel-ratio:2),only screen and (-o-min-device-pixel-ratio:2/1),only screen and (-webkit-min-device-pixel-ratio:2),only screen and (min-device-pixel-ratio:2),only screen and (min-resolution:2dppx),only screen and (min-resolution:192dpi){.synved-social-resolution-normal{display:none}.synved-social-resolution-hidef{display:inline-block}}</style><meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress." /><style type="text/css">.broken_link,a.broken_link{text-decoration:line-through}</style><style type="text/css" id="wp-custom-css">body.page-template-default.page.page-id-1223814 td.column-5{height:100px!important;overflow-y:scroll;max-height:100px}</style><noscript><style>.wpb_animate_when_almost_visible{opacity:1}</style></noscript> <script async src="https://www.googletagmanager.com/gtag/js?id=UA-4815772-1"></script> <script>window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-4815772-1');</script> <script async src="https://powerad.ai/script.js"></script><style id='the7-custom-inline-css' type='text/css'>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</style></head><body class="post-template-default single single-post postid-1251371 single-format-standard wp-embed-responsive dt-responsive-on srcset-enabled btn-flat custom-btn-color custom-btn-hover-color outline-element-decoration phantom-fade phantom-shadow-decoration phantom-main-logo-on sticky-mobile-header top-header first-switch-logo-left first-switch-menu-right second-switch-logo-left second-switch-menu-right right-mobile-menu layzr-loading-on popup-message-style dt-fa-compatibility the7-ver-7.8.1 wpb-js-composer js-comp-ver-6.5.0 vc_responsive"><div id="page"> <a class="skip-link screen-reader-text" href="#content">Skip to content</a><div class="masthead inline-header center widgets full-height shadow-decoration small-mobile-menu-icon dt-parent-menu-clickable" role="banner"><div class="top-bar line-content top-bar-line-hide"><div class="top-bar-bg"></div><div class="left-widgets mini-widgets"><div class="text-area show-on-desktop near-logo-first-switch in-menu-second-switch"><div style="text-align:center">NBA Draft 2021</p><div class="wpcdt-countdown-wrp wpcdt-clearfix"><div id="wpcdt-datecount-1" class="wpcdt-countdown-timer" data-timer="28149774" style="max-width:300px"></div><div class="wpcdt-date-conf" data-conf="{&quot;date&quot;:&quot;2022-06-24 18:00:00&quot;,&quot;animation&quot;:&quot;ticks&quot;,&quot;circlewidth&quot;:&quot;0.05667&quot;,&quot;backgroundwidth&quot;:&quot;1.2&quot;,&quot;backgroundcolor&quot;:&quot;#780e10&quot;,&quot;is_days&quot;:&quot;1&quot;,&quot;daysbackgroundcolor&quot;:&quot;#dd9933&quot;,&quot;is_hours&quot;:&quot;1&quot;,&quot;hoursbackgroundcolor&quot;:&quot;#dd9933&quot;,&quot;is_minutes&quot;:&quot;1&quot;,&quot;minutesbackgroundcolor&quot;:&quot;#dd9933&quot;,&quot;is_seconds&quot;:&quot;0&quot;,&quot;secondsbackgroundcolor&quot;:&quot;#66c5af&quot;,&quot;days_text&quot;:&quot;Days&quot;,&quot;hours_text&quot;:&quot;Hours&quot;,&quot;minutes_text&quot;:&quot;Minutes&quot;,&quot;seconds_text&quot;:&quot;Seconds&quot;}"></div></p></div></p></div></div></div><div class="right-widgets mini-widgets"><div class="text-area show-on-desktop near-logo-first-switch in-menu-second-switch"><div class="nmm-ad-wrapper" style="width:728px;height:90px;"><script async src="https://powerad.ai/hbdirect/5743"></script></div><p></p></div></div></div><header class="header-bar"><div class="branding"><div id="site-title" class="assistive-text">NBADraft.net</div><div id="site-description" class="assistive-text"></div> <a class="same-logo" href="https://www.nbadraft.net/"><img class=" preload-me" src="https://www.nbadraft.net/wp-content/uploads/2019/05/nbadraft-logo.png" srcset="https://www.nbadraft.net/wp-content/uploads/2019/05/nbadraft-logo.png 275w, https://www.nbadraft.net/wp-content/uploads/2019/05/nbadraft-logo2-ret.png 542w" width="275" height="31" sizes="275px" alt="NBADraft.net" /></a></div><ul id="primary-menu" class="main-nav bg-outline-decoration hover-bg-decoration active-bg-decoration outside-item-remove-margin" role="navigation"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-368239 first"><a href='https://www.nbadraft.net/' data-level='1'><span class="menu-item-text"><span class="menu-text">Home</span></span></a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-368259 has-children"><a href='https://www.nbadraft.net/draft/' data-level='1'><span class="menu-item-text"><span class="menu-text">Draft</span></span></a><ul class="sub-nav hover-style-bg level-arrows-on"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-368750 first has-children"><a href='https://www.nbadraft.net/nba-mock-drafts/' data-level='2'><span class="menu-item-text"><span class="menu-text">Mock Drafts</span></span></a><ul class="sub-nav hover-style-bg level-arrows-on"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-368823 first"><a href='https://www.nbadraft.net/nba-mock-drafts/' data-level='3'><span class="menu-item-text"><span class="menu-text">2021 Mock Draft</span></span></a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1245191"><a href='https://www.nbadraft.net/nba-mock-drafts/?year-mock=2022' data-level='3'><span class="menu-item-text"><span class="menu-text">2022 Mock Draft</span></span></a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-368793"><a href='https://www.nbadraft.net/nba-mock-drafts/consensus/' data-level='3'><span class="menu-item-text"><span class="menu-text">Consensus Mock Draft</span></span></a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-368749"><a href='https://www.nbadraft.net/nba-mock-drafts/my-mock-draft/' data-level='3'><span class="menu-item-text"><span class="menu-text">My Mock Drafts</span></span></a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-368794"><a href='https://www.nbadraft.net/nba-mock-drafts/mocks-help/' data-level='3'><span class="menu-item-text"><span class="menu-text">Create Your Own Mock Draft</span></span></a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-368754"><a href='https://www.nbadraft.net/actual-draft/' data-level='2'><span class="menu-item-text"><span class="menu-text">Actual Drafts</span></span></a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-368669 has-children"><a href='https://www.nbadraft.net/outstanding-trades/' data-level='2'><span class="menu-item-text"><span class="menu-text">Outstanding Trades</span></span></a><ul class="sub-nav hover-style-bg level-arrows-on"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1251212 first"><a href='/2021-nba-draft-instant-analysis/' data-level='3'><span class="menu-item-text"><span class="menu-text">Instant Analysis</span></span></a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-368694"><a href='https://www.nbadraft.net/search-players/' data-level='2'><span class="menu-item-text"><span class="menu-text">Search Players</span></span></a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-368254 has-children"><a href='https://www.nbadraft.net/ranking/' data-level='1'><span class="menu-item-text"><span class="menu-text">Rankings</span></span></a><ul class="sub-nav hover-style-bg level-arrows-on"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-368668 first"><a href='https://www.nbadraft.net/ranking/positional/' data-level='2'><span class="menu-item-text"><span class="menu-text">By Position</span></span></a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-368680"><a href='https://www.nbadraft.net/ranking/bigboard/' data-level='2'><span class="menu-item-text"><span class="menu-text">Big Board: Top 100</span></span></a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-368681"><a href='https://www.nbadraft.net/ranking/ncaa/' data-level='2'><span class="menu-item-text"><span class="menu-text">NCAA Players</span></span></a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-368689"><a href='https://www.nbadraft.net/ranking/highschool/' data-level='2'><span class="menu-item-text"><span class="menu-text">High School Players</span></span></a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-368682"><a href='https://www.nbadraft.net/ranking/international/' data-level='2'><span class="menu-item-text"><span class="menu-text">International Players</span></span></a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-368693"><a href='https://www.nbadraft.net/search-players/' data-level='2'><span class="menu-item-text"><span class="menu-text">Search Players</span></span></a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-368255"><a href='https://www.nbadraft.net/articles/' data-level='1'><span class="menu-item-text"><span class="menu-text">Articles</span></span></a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-368253"><a href='https://www.nbadraft.net/news/' data-level='1'><span class="menu-item-text"><span class="menu-text">News</span></span></a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-368256"><a href='https://www.nbadraft.net/blogs/' data-level='1'><span class="menu-item-text"><span class="menu-text">Blogs</span></span></a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-368258"><a href='https://www.nbadraft.net/forum/' data-level='1'><span class="menu-item-text"><span class="menu-text">Forum</span></span></a></li></ul><div class="mini-widgets"><div class="mini-search show-on-desktop near-logo-first-switch near-logo-second-switch popup-search custom-icon"><form class="searchform mini-widget-searchform" role="search" method="get" action="https://www.nbadraft.net/"><label for="the7-micro-widget-search" class="screen-reader-text">Search:</label> <a href="#go" class="submit text-disable"><i class=" mw-icon the7-mw-icon-search-bold"></i></a><div class="popup-search-wrap"> <input type="text" id="the7-micro-widget-search" class="field searchform-s" name="s" value="" placeholder="Type and hit enter …" /><a href="#go" class="search-icon"><i class="the7-mw-icon-search"></i></a></div> <input type="submit" class="assistive-text searchsubmit" value="Go!" /></form></div><div class="mini-login show-on-desktop near-logo-first-switch in-menu-second-switch"><a href="https://www.nbadraft.net/wp-login.php" class="submit">LOGIN</a></div><div class="soc-ico show-on-desktop in-top-bar-right in-menu-second-switch custom-bg disabled-border border-off hover-accent-bg hover-disabled-border  hover-border-off"><a title="Facebook" href="/" target="_blank" class="facebook"><span class="soc-font-icon"></span><span class="screen-reader-text">Facebook</span></a><a title="Twitter" href="/" target="_blank" class="twitter"><span class="soc-font-icon"></span><span class="screen-reader-text">Twitter</span></a></div></div></header></div><div class='dt-close-mobile-menu-icon'><span></span></div><div class='dt-mobile-header'><ul id="mobile-menu" class="mobile-main-nav" role="navigation"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-368239 first"><a href='https://www.nbadraft.net/' data-level='1'><span class="menu-item-text"><span class="menu-text">Home</span></span></a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-368259 has-children"><a href='https://www.nbadraft.net/draft/' data-level='1'><span class="menu-item-text"><span class="menu-text">Draft</span></span></a><ul class="sub-nav hover-style-bg level-arrows-on"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-368750 first has-children"><a href='https://www.nbadraft.net/nba-mock-drafts/' data-level='2'><span class="menu-item-text"><span class="menu-text">Mock Drafts</span></span></a><ul class="sub-nav hover-style-bg level-arrows-on"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-368823 first"><a href='https://www.nbadraft.net/nba-mock-drafts/' data-level='3'><span class="menu-item-text"><span class="menu-text">2021 Mock Draft</span></span></a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1245191"><a href='https://www.nbadraft.net/nba-mock-drafts/?year-mock=2022' data-level='3'><span class="menu-item-text"><span class="menu-text">2022 Mock Draft</span></span></a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-368793"><a href='https://www.nbadraft.net/nba-mock-drafts/consensus/' data-level='3'><span class="menu-item-text"><span class="menu-text">Consensus Mock Draft</span></span></a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-368749"><a href='https://www.nbadraft.net/nba-mock-drafts/my-mock-draft/' data-level='3'><span class="menu-item-text"><span class="menu-text">My Mock Drafts</span></span></a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-368794"><a href='https://www.nbadraft.net/nba-mock-drafts/mocks-help/' data-level='3'><span class="menu-item-text"><span class="menu-text">Create Your Own Mock Draft</span></span></a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-368754"><a href='https://www.nbadraft.net/actual-draft/' data-level='2'><span class="menu-item-text"><span class="menu-text">Actual Drafts</span></span></a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-368669 has-children"><a href='https://www.nbadraft.net/outstanding-trades/' data-level='2'><span class="menu-item-text"><span class="menu-text">Outstanding Trades</span></span></a><ul class="sub-nav hover-style-bg level-arrows-on"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1251212 first"><a href='/2021-nba-draft-instant-analysis/' data-level='3'><span class="menu-item-text"><span class="menu-text">Instant Analysis</span></span></a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-368694"><a href='https://www.nbadraft.net/search-players/' data-level='2'><span class="menu-item-text"><span class="menu-text">Search Players</span></span></a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-368254 has-children"><a href='https://www.nbadraft.net/ranking/' data-level='1'><span class="menu-item-text"><span class="menu-text">Rankings</span></span></a><ul class="sub-nav hover-style-bg level-arrows-on"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-368668 first"><a href='https://www.nbadraft.net/ranking/positional/' data-level='2'><span class="menu-item-text"><span class="menu-text">By Position</span></span></a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-368680"><a href='https://www.nbadraft.net/ranking/bigboard/' data-level='2'><span class="menu-item-text"><span class="menu-text">Big Board: Top 100</span></span></a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-368681"><a href='https://www.nbadraft.net/ranking/ncaa/' data-level='2'><span class="menu-item-text"><span class="menu-text">NCAA Players</span></span></a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-368689"><a href='https://www.nbadraft.net/ranking/highschool/' data-level='2'><span class="menu-item-text"><span class="menu-text">High School Players</span></span></a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-368682"><a href='https://www.nbadraft.net/ranking/international/' data-level='2'><span class="menu-item-text"><span class="menu-text">International Players</span></span></a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-368693"><a href='https://www.nbadraft.net/search-players/' data-level='2'><span class="menu-item-text"><span class="menu-text">Search Players</span></span></a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-368255"><a href='https://www.nbadraft.net/articles/' data-level='1'><span class="menu-item-text"><span class="menu-text">Articles</span></span></a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-368253"><a href='https://www.nbadraft.net/news/' data-level='1'><span class="menu-item-text"><span class="menu-text">News</span></span></a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-368256"><a href='https://www.nbadraft.net/blogs/' data-level='1'><span class="menu-item-text"><span class="menu-text">Blogs</span></span></a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-368258"><a href='https://www.nbadraft.net/forum/' data-level='1'><span class="menu-item-text"><span class="menu-text">Forum</span></span></a></li></ul><div class='mobile-mini-widgets-in-menu'></div></div><div class="blm_container" style="">BLACK LIVES MATTER</div><style>.blm_container{max-width:100%;background-color:black;margin:0 auto;color:yellow;padding:20px 0;text-align:center;font-family:Montserrat,Helvetica,Arial,Verdana,sans-serif;font-weight:700;font-size:25px;text-transform:uppercase;width:1300px}</style><div class="page-title content-left disabled-bg breadcrumbs-off breadcrumbs-mobile-off page-title-responsive-enabled"><div class="wf-wrap"><style>span.author_line{display:block;font-size:12px;line-height:1.3em;padding:0;margin:0 auto;color:#222}span.author_name{display:inline-block;font-size:12px;line-height:1.3em;padding:0;margin:0 auto;color:#790d0d}</style><div class="page-title-head hgroup"><h1 class="entry-title">2021 NBA Draft: Winners and Losers<span class="author_line">By: <span class="author_name">Michael Hopp</span></span></h1></div></div></div><div id="main" class="sidebar-right sidebar-divider-off"><div class="main-gradient"></div><div class="wf-wrap"><div class="wf-container-main"><div id="content" class="content" role="main"><article id="post-1251371" class="post-1251371 post type-post status-publish format-standard has-post-thumbnail category-ncaa category-1 description-off"><div class="post-thumbnail"><img class="preload-me lazy-load" src="data:image/svg+xml,%3Csvg%20xmlns%3D&#39;http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg&#39;%20viewBox%3D&#39;0%200%20700%20394&#39;%2F%3E" data-src="https://www.nbadraft.net/wp-content/uploads/2021/08/21draftclass01.jpg" data-srcset="https://www.nbadraft.net/wp-content/uploads/2021/08/21draftclass01.jpg 700w" width="700" height="394" title="21draftclass01" alt="" /></div><div class="entry-content"><p><strong>Winner:</strong> Detroit Pistons</p><p>Detroit was a winner on June 22nd, when the ping pong balls decided they would have the incredible fortune of drafting <a href="https://www.nbadraft.net/players/cade-cunningham/" class="link-player">Cade Cunningham</a>. The 6’8 point guard was a consensus first-team All-American, the Big 12 Freshman of the Year and the Big 12 Player of the Year. After averaging over 20 points, six boards and three assists with tremendous shooting numbers for the Cowboys, this pick was obvious. Still, the Pistons had other enticing options like <a href="https://www.nbadraft.net/players/evan-mobley/" class="link-player">Evan Mobley</a> and <a href="https://www.nbadraft.net/players/jalen-green/" class="link-player">Jalen Green</a>, and they settled on the right pick. Cunningham will immediately be the Piston’s best player, and a superstar in the coming seasons. Already a phenomenal player at 19-years-old, he can shoot, create, pass, run in transition, rebound, and defend four positions. Aside from nabbing a future multi-time all-star, the Pistons made shrewd selections in Big-Ten standouts Isaiah Livers and Luka Garza. Both have high floors as solid role players and should contribute right away for a rebuilding Detroit team. Garza, the Naismith Men’s College Player of the Year and Wooden Award Winner will provide great offensive skill for a big man, and Livers can bring energy, shooting and versatility. The Pistons still have a way to go in hunting for a championship, but this draft was a huge step in getting there. They grabbed the best player in the draft, and found two second round gems, who are also great leaders, and locker room guys.</p><p><strong>Loser:</strong> Toronto Raptors</p><p>The Raptors had the fourth pick in what was largely considered a four-player draft. That fourth, was <a href="https://www.nbadraft.net/players/jalen-suggs/" class="link-player">Jalen Suggs</a>, a one-year sensation with champion runner-up Gonzaga. Instead of picking the explosive guard, Toronto went with point forward Scottie Barnes. Barnes is still a very good player, especially on the defensive end. His length, wingspan, and athleticism project him to be an impact stopper from day one. However, Suggs and the Raptors were a natural fit.  Suggs isn’t as versatile on defense as Barnes is, but he has a much higher floor and ceiling on offense. He can dominate with or without the ball, can generate good looks in half court and transition, and is a better three-point shooter than the former Seminole. Suggs being a combo guard also gave them the flexibility of him playing next to Van Vleet if they wanted to start him. Barnes is going to be a productive NBA defender and gives the Raptors great length with OG Anunoby on the floor, but Suggs was such a perfect fit for what they needed on offense, which Barnes simply can’t provide at this point in his career. With Lowry likely being shipped off to the Heat for Goran Dragic and Precious Achiuwa, perhaps the Raptors had their late first round pick from last year Malachi Flynn in mind when they decided on Barnes. Had they opted for Suggs, it would have been hard to get the value they see in Flynn back, or allow him the opportunity to develop. Players with Barnes skill set and length are rare. But in the end Suggs&#8217; potential to become a franchise talent was likely a mistake to pass on.</p><p><strong>Winner:</strong> Golden State Warriors</p><p>Steph needs some more help. With a healthy Klay Thompson, the splash bros are dangerous enough to mitigate their lack of depth. Without him, the Warriors end up picking in the lottery. Stuck between helping the current stars while also building for the future, Golden State managed the draft perfectly. They grabbed Johnathon Kuminga with the 7th pick, who finds a match made in heaven for him as well. Not yet a capable shooter, Kuminga can play to his strengths while surrounded by Curry and Thompson. Kuminga won’t have the pressure to fill up the stat sheet that other top picks will and can instead be given time to continue developing his offensive skill set while contributing as a defensive chess piece, athlete, and slasher. With the 14th pick, the Warriors struck gold again, picking Moses Moody from Arkansas. The 19-year-old gives the Warriors another scoring outlet, as the former Razorback poured in over 16 points per game and almost 36% of his triples. The Warriors were reportedly considering Moody with their 7th pick early on, and got very lucky that he was available for them seven picks later. A natural scorer, Moody can lead the bench unit, or pair with the splash bros. Either way, he brings a much-needed scoring spark and elite level athleticism, and both will help shore up what was a terrible bench for the Warriors last season. Plus, Kuminga can learn from star defender Draymond Green, which could be vital for his long-term development as one of the game’s potential standout defenders.</p><p><strong>Loser:</strong> San Antonio Spurs</p><p>The Spurs have long been one of the most successful franchises in all of sports. It is safe to say their front office isn’t used to picking in the lottery, until last year they may not even have known they were allowed to pick before 24th. They had not picked in the lottery since they picked Tim Duncan first overall in 1997. This year, they went with a surprise in Alabama guard <a href="https://www.nbadraft.net/players/joshua-primo/" class="link-player">Joshua Primo</a>. The draft’s youngest player, Primo didn’t get much playing time behind a tremendous starting five for the Crimson Tide. We had him rated at 19th overall, so it&#8217;s not like we feel he isn&#8217;t talented. He certainly has upside as a 6’6 shot maker, shooter and defender. The hope is that he can develop into one of the better two-way players in the league. That is still a serious roll of the dice, as Primo scored a hair over eight points per game this season. He doesn’t pass, and hasn&#8217;t yet developed offensive creation, a very important skill for guards. He is too small to play small forward, and not good enough as a primary ball handler to play the point guard spot, at this point. The Spurs are in rebuilding mode and have the time to wait as the 18-year-old gains more understanding of how to be an effective NBA player. However, his upside doesn;t seem to be as great as some other potential picks like <a href="https://www.nbadraft.net/players/kai-jones/" class="link-player">Kai Jones</a> or <a href="https://www.nbadraft.net/players/keon-johnson/" class="link-player">Keon Johnson</a>.  Add in that Derrick White and Dejounte Murray are good starters, and they could have invested in a position that they haven’t already addressed so much draft capital in. Iowa sharpshooter Joe Wieskamp is a solid value selection at 41, but the selection of Primo at 12 is a bit of a head scratch-er.</p><p><strong>Winner:</strong> Charlotte Hornets</p><p>The Hornets probably couldn’t wait to run to the podium as soon as they saw that <a href="https://www.nbadraft.net/players/james-bouknight/" class="link-player">James Bouknight</a> was available with the 11th pick. The 6’5 shooting guard is a fluid and athletic scorer, and one that the Hornets could really use. Bouknight can immediately be one of the Hornet’s better offensive contributors and will likely be the leading scorer of the bench unit in his first season. While he isn’t a sniper from long range, his low average was in large part due to all the attention being on him at UConn. Bouknight can play the role that Malik Monk will likely leave, but with more efficiency, especially finishing around the rim. The former Husky was one of the best players in the class, and it is amazing that he fell all the way to 11 for the Hornets, who needed another scoring threat. They also stockpiled some solid selections behind him, grabbing bouncy big man Kai Jones with the 19th pick after trading with the Knicks. Another great fit for Charlotte, as they really needed to address the big man situation. Jones gives them an extremely athletic, rim-running big to play with their guards. He can also be a force on the interior defensively. They also picked JT Thor and Scottie Lewis, who should be able to be solid role players for the Hornets. Still, the main success is Bouknight, a fearless and terrific scorer, and a player who fits the needs of Charlotte perfectly. He was one of the best picks of the first round.</p><p><strong>Loser:</strong> Indiana Pacers</p><p>The Pacers have been stuck in mediocrity for a long time and had a tumultuous season this year that ended with firing Head Coach Nate Bjorkgren after just one season. The Pacers were one of the teams that desperately needed to crush the draft in order to escape the purgatory of losing in the first round. They picked Oregon standout Chris Duarte with the 13th selection of the draft. Duarte had an amazing season for the Ducks and is one of the readiest prospects of the class. He will immediately be an important player for the Pacers. Even though Duarte can contribute, this was not a smart selection because of Duarte’s ceiling. Featured in my article of most overrated players, Duarte only had one good season, and might not be able to recapture that success against more seasoned competitors. He is a 24-year-old, and one of the older draft picks ever. He is a limited athlete and was dominating against teenagers that were years behind him in their development. The Pacers need more immediate help, but they also need some more star power. It would have been worth a swing to see if they could hit on a player that turns into a star. Duarte doesn’t really have a chance of being that and will likely be a good 3-And-D player. It isn’t bad to get high-caliber role players, but with such a high section, and a team in need of another star, this would have been a spot to swing for the fences. They also traded to select Kentucky big man Isaiah Jackson, who was also detailed in the overrated players article. He is a great athlete, but doesn’t provide any scoring punch, is not a good rebounder or defender, and wasn’t able to dominate against college bigs. This time the Pacers did pick a long term, higher upside project, but they did so with a guy who has so many red flags. He can’t stretch the floor or create his own offense, and he can’t defend the interior well. What else are bigs supposed to do besides defend the interior and be a useful offensive player either from three or in the post? This needed to be a good draft for the Pacers after being seemingly endlessly eliminated in the first round, instead they took the draft’s oldest prospect, a likely role player, and a big man who couldn’t contribute for a college team.</p><p><strong>Winners:</strong> Late Round Steals</p><p>This was known as a four-player draft, but when the list of withdrawals came out, the number of players that elected to stay in was substantial, making this an extremely deep draft in the mid to late second round. That depth will almost certainly produce some hidden gems. One name that stands out is reigning national champion <a href="https://www.nbadraft.net/players/jared-butler/" class="link-player">Jared Butler</a>. The former Baylor star put on a clinic this season and was often the best player on the court during their title run. He was taken by the Jazz with the 40th selection, and not only be an immediate playmaker and defender but has some star upside. Even though he lacks elite burst, his tremendous shooting, shot selection, size and defense will all translate to a quality NBA player with upside to be a high profile, very good offensive player. Another late steal was <a href="https://www.nbadraft.net/players/ayo-dosunmu/" class="link-player">Ayo Dosunmu</a>. The Illinois guard was grabbed with the 38th pick by the Bulls and was one of the more athletic and quick guards in the entire class. He can get to the rim at will, fills the stat sheet with rebounds and assists and can play on or off the ball. Finally, <a href="https://www.nbadraft.net/players/sharife-cooper/" class="link-player">Sharife Cooper</a>, <a href="https://www.nbadraft.net/players/filip-petrusev/" class="link-player">Filip Petrusev</a>  and <a href="https://www.nbadraft.net/players/charles-bassey/" class="link-player">Charles Bassey</a> were fantastic selections. Bassey, a member of my underrated draft article, provides the 76ers with a gritty and athletic bench center to back up Joel Embiid. Getting a useful and immediate contributor with such a low selection is a win for Philadelphia. Petrusev improved his shooting considerably and was once thought to be a potential first rounder. He could end up a steal at 50. On the other end of the size spectrum, 6’0 Sharife Cooper will be fun to watch with the Hawks. He can back up Trae Young, and mimic some of his passing wizardry, pace and scoring. He was on my overrated prospects article, but his talent in the mid-forties is undeniable. Like Carlos Boozer many years ago (2002), he literally flipped from overrated to underrated on draft night. The questions over his size, shooting and defense are real, but his offensive abilities are as well. He can learn behind Young and is worth a shot that late to see if he can become a very good player down the road.</p> <a class="synved-social-button synved-social-button-share synved-social-size-32 synved-social-resolution-single synved-social-provider-facebook nolightbox" data-provider="facebook" target="_blank" rel="nofollow" title="Share on Facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.nbadraft.net%2F2021-nba-draft-winners-and-losers%2F&#038;t=2021%20NBA%20Draft%3A%20Winners%20and%20Losers&#038;s=100&#038;p&#091;url&#093;=https%3A%2F%2Fwww.nbadraft.net%2F2021-nba-draft-winners-and-losers%2F&#038;p&#091;images&#093;&#091;0&#093;=https%3A%2F%2Fwww.nbadraft.net%2Fwp-content%2Fuploads%2F2021%2F08%2F21draftclass01.jpg&#038;p&#091;title&#093;=2021%20NBA%20Draft%3A%20Winners%20and%20Losers" style="font-size: 0px; width:32px;height:32px;margin:0;margin-bottom:5px;margin-right:5px;"><img alt="Facebook" title="Share on Facebook" class="synved-share-image synved-social-image synved-social-image-share" width="32" height="32" style="display: inline; width:32px;height:32px; margin: 0; padding: 0; border: none; box-shadow: none;" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://www.nbadraft.net/wp-content/plugins/social-media-feather/synved-social/addons/extra-icons/image/social/clearslate/64x64/facebook.png" /><noscript><img alt="Facebook" title="Share on Facebook" class="synved-share-image synved-social-image synved-social-image-share" width="32" height="32" style="display: inline; width:32px;height:32px; margin: 0; padding: 0; border: none; box-shadow: none;" src="https://www.nbadraft.net/wp-content/plugins/social-media-feather/synved-social/addons/extra-icons/image/social/clearslate/64x64/facebook.png" /></noscript></a><a class="synved-social-button synved-social-button-share synved-social-size-32 synved-social-resolution-single synved-social-provider-twitter nolightbox" data-provider="twitter" target="_blank" rel="nofollow" title="Share on Twitter" href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.nbadraft.net%2F2021-nba-draft-winners-and-losers%2F&#038;text=Hey%20check%20this%20out" style="font-size: 0px; width:32px;height:32px;margin:0;margin-bottom:5px;margin-right:5px;"><img alt="twitter" title="Share on Twitter" class="synved-share-image synved-social-image synved-social-image-share" width="32" height="32" style="display: inline; width:32px;height:32px; margin: 0; padding: 0; border: none; box-shadow: none;" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://www.nbadraft.net/wp-content/plugins/social-media-feather/synved-social/addons/extra-icons/image/social/clearslate/64x64/twitter.png" /><noscript><img alt="twitter" title="Share on Twitter" class="synved-share-image synved-social-image synved-social-image-share" width="32" height="32" style="display: inline; width:32px;height:32px; margin: 0; padding: 0; border: none; box-shadow: none;" src="https://www.nbadraft.net/wp-content/plugins/social-media-feather/synved-social/addons/extra-icons/image/social/clearslate/64x64/twitter.png" /></noscript></a><a class="synved-social-button synved-social-button-share synved-social-size-32 synved-social-resolution-single synved-social-provider-reddit nolightbox" data-provider="reddit" target="_blank" rel="nofollow" title="Share on Reddit" href="https://www.reddit.com/submit?url=https%3A%2F%2Fwww.nbadraft.net%2F2021-nba-draft-winners-and-losers%2F&#038;title=2021%20NBA%20Draft%3A%20Winners%20and%20Losers" style="font-size: 0px; width:32px;height:32px;margin:0;margin-bottom:5px;margin-right:5px;"><img alt="reddit" title="Share on Reddit" class="synved-share-image synved-social-image synved-social-image-share" width="32" height="32" style="display: inline; width:32px;height:32px; margin: 0; padding: 0; border: none; box-shadow: none;" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://www.nbadraft.net/wp-content/plugins/social-media-feather/synved-social/addons/extra-icons/image/social/clearslate/64x64/reddit.png" /><noscript><img alt="reddit" title="Share on Reddit" class="synved-share-image synved-social-image synved-social-image-share" width="32" height="32" style="display: inline; width:32px;height:32px; margin: 0; padding: 0; border: none; box-shadow: none;" src="https://www.nbadraft.net/wp-content/plugins/social-media-feather/synved-social/addons/extra-icons/image/social/clearslate/64x64/reddit.png" /></noscript></a><a class="synved-social-button synved-social-button-share synved-social-size-32 synved-social-resolution-single synved-social-provider-mail nolightbox" data-provider="mail" rel="nofollow" title="Share by email" href="/cdn-cgi/l/email-protection#417e3234232b2422357c737173706473710f0300647371053320273564720064737116282f2f243332647371202f256473710d2e3224333267627172797a232e25387c092438647371222924222a647371352928326473712e34357b64737129353531326472006473076473073636366f2f232025332027356f2f2435647307737173706c2f23206c25332027356c36282f2f2433326c202f256c2d2e32243332647307" style="font-size: 0px; width:32px;height:32px;margin:0;margin-bottom:5px;"><img alt="mail" title="Share by email" class="synved-share-image synved-social-image synved-social-image-share" width="32" height="32" style="display: inline; width:32px;height:32px; margin: 0; padding: 0; border: none; box-shadow: none;" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://www.nbadraft.net/wp-content/plugins/social-media-feather/synved-social/addons/extra-icons/image/social/clearslate/64x64/mail.png" /><noscript><img alt="mail" title="Share by email" class="synved-share-image synved-social-image synved-social-image-share" width="32" height="32" style="display: inline; width:32px;height:32px; margin: 0; padding: 0; border: none; box-shadow: none;" src="https://www.nbadraft.net/wp-content/plugins/social-media-feather/synved-social/addons/extra-icons/image/social/clearslate/64x64/mail.png" /></noscript></a></div><div class="post-meta wf-mobile-collapsed"><div class="entry-meta"><a class="author vcard" href="https://www.nbadraft.net/author/michael_hopp/" title="View all posts by Michael Hopp" rel="author">By <span class="fn">Michael Hopp</span></a><a href="https://www.nbadraft.net/2021/08/01/" title="10:23 pm" class="data-link" rel="bookmark"><time class="entry-date updated" datetime="2021-08-01T22:23:41-07:00">August 1, 2021</time></a><a href="https://www.nbadraft.net/2021-nba-draft-winners-and-losers/#respond" class="comment-link">Leave a comment</a></div></div><div class="author-info entry-author"> <span class="author-avatar no-avatar"></span><div class="author-description"><h4><span class="author-heading">Author:</span>&nbsp;Michael Hopp</h4><p class="author-bio"></p></div></div><nav class="navigation post-navigation" role="navigation"><h2 class="screen-reader-text">Post navigation</h2><div class="nav-links"><a class="nav-previous" href="https://www.nbadraft.net/2021-nba-draft-western-conference-draft-grades/" rel="prev"><i class="icomoon-the7-font-the7-arrow-29-3" aria-hidden="true"></i><span class="meta-nav" aria-hidden="true">Previous</span><span class="screen-reader-text">Previous post:</span><span class="post-title h4-size">2021 NBA Draft: Western Conference Draft Grades</span></a><span class="nav-next disabled"></span></div></nav></article><div id="comments" class="comments-area"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2021-nba-draft-winners-and-losers/#respond" style="display:none;">Cancel reply</a></small></h3><p class="must-log-in text-small">You must be <a href="https://www.nbadraft.net/wp-login.php?redirect_to=https%3A%2F%2Fwww.nbadraft.net%2F2021-nba-draft-winners-and-losers%2F">logged in</a> to post a comment.</p></div><p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p></div></div><aside id="sidebar" class="sidebar"><div class="sidebar-content widget-divider-off"><section id="bbp_login_widget-2" class="widget bbp_widget_login"><form method="post" action="https://www.nbadraft.net/wp-login.php" class="bbp-login-form"><fieldset><legend>Log In</legend><div class="bbp-username"> <label for="user_login">Username: </label> <input type="text" name="log" value="" size="20" id="user_login" tabindex="101" /></div><div class="bbp-password"> <label for="user_pass">Password: </label> <input type="password" name="pwd" value="" size="20" id="user_pass" tabindex="102" /></div><div class="bbp-remember-me"> <input type="checkbox" name="rememberme" value="forever" id="rememberme" tabindex="103" /> <label for="rememberme">Remember Me</label></div><div class="bbp-submit-wrapper"> <button type="submit" name="user-submit" id="user-submit" tabindex="104" class="button submit user-submit">Log In</button> <input type="hidden" name="user-cookie" value="1" /><input type="hidden" id="bbp_redirect_to" name="redirect_to" value="https://www.nbadraft.net/2021-nba-draft-winners-and-losers/" /><input type="hidden" id="_wpnonce" name="_wpnonce" value="f30d6edadb" /><input type="hidden" name="_wp_http_referer" value="/2021-nba-draft-winners-and-losers/" /></div><div class="bbp-login-links"> <a href="/wp-login.php?action=register" title="Register" class="bbp-register-link">Register</a> <a href="/wp-login?action=lostpassword" title="Lost Password" class="bbp-lostpass-link">Lost Password</a></div></fieldset></form></section><section id="search-3" class="widget widget_search"><div class="widget-title">Search</div><form class="searchform" role="search" method="get" action="https://www.nbadraft.net/"> <label for="the7-search" class="screen-reader-text">Search:</label> <input type="text" id="the7-search" class="field searchform-s" name="s" value="" placeholder="Type and hit enter &hellip;" /> <input type="submit" class="assistive-text searchsubmit" value="Go!" /> <a href="#go" class="submit"></a></form></section><section id="synved_social_share-2" class="widget widget_synved_social_share"><div><a class="synved-social-button synved-social-button-share synved-social-size-32 synved-social-resolution-single synved-social-provider-facebook nolightbox" data-provider="facebook" target="_blank" rel="nofollow" title="Share on Facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.nbadraft.net%2F2021-nba-draft-winners-and-losers%2F&#038;t=2021%20NBA%20Draft%3A%20Winners%20and%20Losers&#038;s=100&#038;p&#091;url&#093;=https%3A%2F%2Fwww.nbadraft.net%2F2021-nba-draft-winners-and-losers%2F&#038;p&#091;images&#093;&#091;0&#093;=https%3A%2F%2Fwww.nbadraft.net%2Fwp-content%2Fuploads%2F2021%2F08%2F21draftclass01.jpg&#038;p&#091;title&#093;=2021%20NBA%20Draft%3A%20Winners%20and%20Losers" style="font-size: 0px; width:32px;height:32px;margin:0;margin-bottom:5px;margin-right:5px;"><img alt="Facebook" title="Share on Facebook" class="synved-share-image synved-social-image synved-social-image-share" width="32" height="32" style="display: inline; width:32px;height:32px; margin: 0; padding: 0; border: none; box-shadow: none;" src="https://www.nbadraft.net/wp-content/plugins/social-media-feather/synved-social/addons/extra-icons/image/social/clearslate/64x64/facebook.png" /></a><a class="synved-social-button synved-social-button-share synved-social-size-32 synved-social-resolution-single synved-social-provider-twitter nolightbox" data-provider="twitter" target="_blank" rel="nofollow" title="Share on Twitter" href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.nbadraft.net%2F2021-nba-draft-winners-and-losers%2F&#038;text=Hey%20check%20this%20out" style="font-size: 0px; width:32px;height:32px;margin:0;margin-bottom:5px;margin-right:5px;"><img alt="twitter" title="Share on Twitter" class="synved-share-image synved-social-image synved-social-image-share" width="32" height="32" style="display: inline; width:32px;height:32px; margin: 0; padding: 0; border: none; box-shadow: none;" src="https://www.nbadraft.net/wp-content/plugins/social-media-feather/synved-social/addons/extra-icons/image/social/clearslate/64x64/twitter.png" /></a><a class="synved-social-button synved-social-button-share synved-social-size-32 synved-social-resolution-single synved-social-provider-reddit nolightbox" data-provider="reddit" target="_blank" rel="nofollow" title="Share on Reddit" href="https://www.reddit.com/submit?url=https%3A%2F%2Fwww.nbadraft.net%2F2021-nba-draft-winners-and-losers%2F&#038;title=2021%20NBA%20Draft%3A%20Winners%20and%20Losers" style="font-size: 0px; width:32px;height:32px;margin:0;margin-bottom:5px;margin-right:5px;"><img alt="reddit" title="Share on Reddit" class="synved-share-image synved-social-image synved-social-image-share" width="32" height="32" style="display: inline; width:32px;height:32px; margin: 0; padding: 0; border: none; box-shadow: none;" src="https://www.nbadraft.net/wp-content/plugins/social-media-feather/synved-social/addons/extra-icons/image/social/clearslate/64x64/reddit.png" /></a><a class="synved-social-button synved-social-button-share synved-social-size-32 synved-social-resolution-single synved-social-provider-mail nolightbox" data-provider="mail" rel="nofollow" title="Share by email" href="/cdn-cgi/l/email-protection#4d723e382f27282e39707f7d7f7c687f7d030f0c687f7d093f2c2b39687e0c687f7d1a242323283f3e687f7d2c2329687f7d01223e283f3e6b6e7d7e75762f22293470052834687f7d2e25282e26687f7d3925243e687f7d22383977687f7d2539393d3e687e0c687f0b687f0b3a3a3a63232f2c293f2c2b3963232839687f0b7f7d7f7c60232f2c60293f2c2b39603a242323283f3e602c23296021223e283f3e687f0b" style="font-size: 0px; width:32px;height:32px;margin:0;margin-bottom:5px;"><img alt="mail" title="Share by email" class="synved-share-image synved-social-image synved-social-image-share" width="32" height="32" style="display: inline; width:32px;height:32px; margin: 0; padding: 0; border: none; box-shadow: none;" src="https://www.nbadraft.net/wp-content/plugins/social-media-feather/synved-social/addons/extra-icons/image/social/clearslate/64x64/mail.png" /></a></div></section></div></aside></div></div></div><footer id="footer" class="footer solid-bg"><div class="wf-wrap"><div class="wf-container-footer"><div class="wf-container"><section id="custom_html-3" class="widget_text widget widget_custom_html wf-cell wf-1-3"><div class="textwidget custom-html-widget"><div id="fb-root"></div> <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async defer crossorigin="anonymous" src="https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v3.3"></script> <div class="fb-page" data-href="https://facebook.com/nbadraft.net" data-tabs="timeline" data-width="" data-height="350" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="false"><blockquote cite="https://facebook.com/nbadraft.net" class="fb-xfbml-parse-ignore"><a href="https://facebook.com/nbadraft.net">NBADraft.net</a></blockquote></div></div></section><section id="custom_html-2" class="widget_text widget widget_custom_html wf-cell wf-1-3"><div class="textwidget custom-html-widget"><a class="twitter-timeline" href="https://twitter.com/nbadraftnet?ref_src=twsrc%5Etfw" data-height="350" data-link-color="#790E0E">Tweets by nbadraftnet</a> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></div></section><section id="custom_html-4" class="widget_text widget widget_custom_html wf-cell wf-1-3"><div class="textwidget custom-html-widget"><div class="OUTBRAIN" data-src="" data-widget-id="TF_6"></div> <script type="text/javascript" async="async" src="//widgets.outbrain.com/outbrain.js"></script> </div></section></div></div></div><div id="bottom-bar" class="logo-left" role="contentinfo"><div class="wf-wrap"><div class="wf-container-bottom"><div class="wf-float-left">© 2021 Sports Phenoms, Inc., All Rights Reserved |
This site has no affiliation with the National Basketball Association | Website by <a href="https://sofcorp.com" target="blank">SOF, Inc.</a></div><div class="wf-float-right"><div class="bottom-text-block"><p><a href="/terms-of-use/">Terms of Use</a> | <a href="/privacy-policy">Privacy Policy</a></p></div></div></div></div></div></footer> <a href="#" class="scroll-top"><span class="screen-reader-text">Go to Top</span></a></div><style>body.logged-in .lrm-hide-if-logged-in{display:none!important}body.logged-in [class*='lrm-hide-if-logged-in']{display:none!important}body:not(.logged-in) .lrm-show-if-logged-in{display:none!important}body:not(.logged-in) [class*='lrm-show-if-logged-in']{display:none!important}</style><div class="lrm-main lrm-font-svg lrm-user-modal" style="visibility: hidden;"><div class="lrm-user-modal-container"><ul class="lrm-switcher -is-not-login-only"><li><a href="#0" class="lrm-switch-to-link lrm-switch-to--login lrm-ficon-login "> Sign in </a></li><li><a href="#0" class="lrm-switch-to-link lrm-switch-to--register lrm-ficon-register "> New account </a></li></ul><div class="lrm-signin-section "><form class="lrm-form" action="#0" data-action="login"><div class="lrm-integrations lrm-integrations--login"></div><p class="lrm-form-message lrm-form-message--init"></p><div class="fieldset"> <label class="image-replace lrm-email lrm-ficon-mail" title="Email or Username"></label> <input name="username" class="full-width has-padding has-border" type="text" aria-label="Email or Username" placeholder="Email or Username" required value="" autocomplete="username" data-autofocus="1"> <span class="lrm-error-message"></span></div><div class="fieldset"> <label class="image-replace lrm-password lrm-ficon-key" title="Password"></label> <input name="password" class="full-width has-padding has-border" type="password" aria-label="Password" placeholder="Password" required value=""> <span class="lrm-error-message"></span> <span class="hide-password lrm-ficon-eye" data-show="Show" data-hide="Hide" aria-label="Show"></span></div><div class="fieldset"> <label class="lrm-nice-checkbox__label lrm-remember-me-checkbox">Remember me <input type="checkbox" class="lrm-nice-checkbox lrm-remember-me" name="remember-me" checked><div class="lrm-nice-checkbox__indicator"></div> </label></div><div class="lrm-integrations lrm-integrations--login lrm-integrations-before-btn"></div><div class="lrm-integrations-otp"></div><div class="fieldset fieldset--submit"> <button class="full-width has-padding" type="submit"> Log in </button></div><div class="lrm-integrations lrm-integrations--login"></div><input type="hidden" name="redirect_to" value=""> <input type="hidden" name="lrm_action" value="login"> <input type="hidden" name="wp-submit" value="1"> <input type="hidden" name="lp-ajax" value="login"><input type="hidden" id="security-login" name="security-login" value="adc9fd53d2" /><input type="hidden" name="_wp_http_referer" value="/2021-nba-draft-winners-and-losers/" /> <span class="wpcf7-submit" style="display: none;"></span></form><p class="lrm-form-bottom-message"><a href="#0" class="lrm-switch-to--reset-password">Forgot your password?</a></p></div><div class="lrm-signup-section "><form class="lrm-form" action="#0" data-action="registration"><div class="lrm-integrations lrm-integrations--register"></div><p class="lrm-form-message lrm-form-message--init"></p><div class="fieldset fieldset--username"> <label class="image-replace lrm-username lrm-ficon-user" for="signup-username" title="Username*"></label> <input name="username" class="full-width has-padding has-border" id="signup-username" type="text" placeholder="Username*" required aria-label="Username*"> <span class="lrm-error-message"></span></div><div class="fieldset clearfix"><div class="lrm-col-half-width lrm-col-first fieldset--first-name"> <label class="image-replace lrm-username lrm-ficon-user" for="signup-first-name" title="First name*"></label> <input name="first-name" class="full-width has-padding has-border" id="signup-first-name" type="text" placeholder="First name*" required aria-label="First name*"> <span class="lrm-error-message"></span></div><div class="lrm-col-half-width lrm-col-last fieldset--last-name"> <label class="image-replace lrm-username lrm-ficon-user" for="signup-last-name" title="Last name"></label> <input name="last-name" class="full-width has-padding has-border" id="signup-last-name" type="text" placeholder="Last name" aria-label="Last name"> <span class="lrm-error-message"></span></div></div><div class="fieldset fieldset--email"> <label class="image-replace lrm-email lrm-ficon-mail" for="signup-email" title="Email*"></label> <input name="email" class="full-width has-padding has-border" id="signup-email" type="email" placeholder="Email*" required autocomplete="off" aria-label="Email*"> <span class="lrm-error-message"></span></div><div class="lrm-integrations lrm-integrations--register"></div><div class="fieldset fieldset--terms"><label class="lrm-nice-checkbox__label lrm-accept-terms-checkbox">I agree with the <a href="/terms-of-use">Terms</a>. <input type="checkbox" class="lrm-nice-checkbox lrm-accept-terms" name="registration_terms" value="yes"> <span class="lrm-error-message"></span><div class="lrm-nice-checkbox__indicator"></div> </label></div><div class="lrm-info lrm-info--register"></div><div class="fieldset fieldset--submit"> <button class="full-width has-padding" type="submit"> Create account </button></div><div class="lrm-integrations lrm-integrations--register"></div><input type="hidden" name="redirect_to" value=""> <input type="hidden" name="lrm_action" value="signup"> <input type="hidden" name="wp-submit" value="1"> <input type="hidden" name="is_popup_register" value="1"> <input type="hidden" id="security-signup" name="security-signup" value="a1c91393e0" /><input type="hidden" name="_wp_http_referer" value="/2021-nba-draft-winners-and-losers/" /> <span class="wpcf7-submit" style="display: none;"></span></form></div><div class="lrm-reset-password-section "><form class="lrm-form" action="#0" data-action="lost-password"><p class="lrm-form-message">Lost your password? Please enter your email address. You will receive mail with link to set new password.</p><div class="fieldset"> <label class="image-replace lrm-email lrm-ficon-mail" title="Email or Username"></label> <input class="full-width has-padding has-border" name="user_login" type="text" required placeholder="Email or Username" data-autofocus="1" aria-label="Email or Username"> <span class="lrm-error-message"></span></div><div class="lrm-integrations lrm-integrations--reset-pass"></div><input type="hidden" name="lrm_action" value="lostpassword"> <input type="hidden" name="wp-submit" value="1"> <input type="hidden" id="security-lostpassword" name="security-lostpassword" value="783767ccfe" /><input type="hidden" name="_wp_http_referer" value="/2021-nba-draft-winners-and-losers/" /><div class="fieldset fieldset--submit"> <button class="full-width has-padding" type="submit"> Reset password </button></div> <span class="wpcf7-submit" style="display: none;"></span></form><p class="lrm-form-bottom-message"><a href="#0" class="lrm-switch-to--login">Back to login</a></p></div> <a href="#0" class="lrm-close-form">close</a></div></div> <script type='text/javascript' src='https://www.nbadraft.net/wp-content/themes/dt-the7/js/main.min.js?ver=7.8.1'></script> <script type='text/javascript'>/* <![CDATA[ */ var params = {"is_logged_in":"false","is_admin":"false","this_domain":"https:\/\/www.nbadraft.net","user_id":"0","bbp_profile_link":"false"}; /* ]]> */</script> <script type='text/javascript' src='https://www.nbadraft.net/wp-content/plugins/ajax-login-and-registration-modal-popup/assets/lrm-menu-hook.js?ver=55'></script> <script type='text/javascript'>/* <![CDATA[ */ var LRM = {"password_zxcvbn_js_src":"https:\/\/www.nbadraft.net\/wp-includes\/js\/zxcvbn.min.js","redirect_url":"","ajax_url":"https:\/\/www.nbadraft.net\/?lrm=1","is_user_logged_in":"","reload_after_login":null,"selectors_mapping":{"login":"","register":""},"is_customize_preview":"","l10n":{"password_is_good":"Good Password","password_is_strong":"Strong Password","password_is_short":"Too Short Password","password_is_bad":"Bad Password","passwords_is_mismatch":"Passwords is mismatch!"}}; /* ]]> */</script> <script type='text/javascript' src='https://www.nbadraft.net/wp-content/plugins/ajax-login-and-registration-modal-popup/assets/lrm-core.js?ver=55'></script> <script type='text/javascript'>/* <![CDATA[ */ var wp_ulike_params = {"ajax_url":"https:\/\/www.nbadraft.net\/wp-admin\/admin-ajax.php","notifications":"1"}; /* ]]> */</script> <script type='text/javascript' src='https://www.nbadraft.net/wp-content/plugins/wp-ulike/assets/js/wp-ulike.min.js?ver=3.6.2'></script> <script type='text/javascript' src='https://www.nbadraft.net/wp-content/plugins/nba_mock/assets/js/nba_mock_custom.js?ver=1.02'></script> <script type='text/javascript' src='https://www.nbadraft.net/wp-includes/js/comment-reply.min.js?ver=bba49859d2fa3ea8fa1f079d3eeafc8d'></script> <script type='text/javascript' src='https://www.nbadraft.net/wp-includes/js/wp-embed.min.js?ver=bba49859d2fa3ea8fa1f079d3eeafc8d'></script> <script type='text/javascript' src='https://www.nbadraft.net/wp-content/plugins/countdown-timer-ultimate/assets/js/wpcdt-timecircles.js?ver=1.2.3'></script> <script type='text/javascript' src='https://www.nbadraft.net/wp-content/plugins/countdown-timer-ultimate/assets/js/wpcdt-public-js.js?ver=1.2.3'></script> <script>(function(w, d){
	var b = d.getElementsByTagName("body")[0];
	var s = d.createElement("script"); s.async = true;
	s.src = !("IntersectionObserver" in w) ? "https://www.nbadraft.net/wp-content/plugins/wp-rocket/inc/front/js/lazyload-8.15.2.min.js" : "https://www.nbadraft.net/wp-content/plugins/wp-rocket/inc/front/js/lazyload-10.17.min.js";
	w.lazyLoadOptions = {
		elements_selector: "img,iframe",
		data_src: "lazy-src",
		data_srcset: "lazy-srcset",
		data_sizes: "lazy-sizes",
		skip_invisible: false,
		class_loading: "lazyloading",
		class_loaded: "lazyloaded",
		threshold: 300,
		callback_load: function(element) {
			if ( element.tagName === "IFRAME" && element.dataset.rocketLazyload == "fitvidscompatible" ) {
				if (element.classList.contains("lazyloaded") ) {
					if (typeof window.jQuery != "undefined") {
						if (jQuery.fn.fitVids) {
							jQuery(element).parent().fitVids();
						}
					}
				}
			}
		}
	}; // Your options here. See "recipes" for more information about async.
	b.appendChild(s);
}(window, document));

// Listen to the Initialized event
window.addEventListener('LazyLoad::Initialized', function (e) {
    // Get the instance and puts it in the lazyLoadInstance variable
	var lazyLoadInstance = e.detail.instance;

	var observer = new MutationObserver(function(mutations) {
		mutations.forEach(function(mutation) {
			lazyLoadInstance.update();
		} );
	} );
	
	var b      = document.getElementsByTagName("body")[0];
	var config = { childList: true, subtree: true };
	
	observer.observe(b, config);
}, false);</script> <div class="pswp" tabindex="-1" role="dialog" aria-hidden="true"><div class="pswp__bg"></div><div class="pswp__scroll-wrap"><div class="pswp__container"><div class="pswp__item"></div><div class="pswp__item"></div><div class="pswp__item"></div></div><div class="pswp__ui pswp__ui--hidden"><div class="pswp__top-bar"><div class="pswp__counter"></div> <button class="pswp__button pswp__button--close" title="Close (Esc)"></button> <button class="pswp__button pswp__button--share" title="Share"></button> <button class="pswp__button pswp__button--fs" title="Toggle fullscreen"></button> <button class="pswp__button pswp__button--zoom" title="Zoom in/out"></button><div class="pswp__preloader"><div class="pswp__preloader__icn"><div class="pswp__preloader__cut"><div class="pswp__preloader__donut"></div></div></div></div></div><div class="pswp__share-modal pswp__share-modal--hidden pswp__single-tap"><div class="pswp__share-tooltip"></div></div> <button class="pswp__button pswp__button--arrow--left" title="Previous (arrow left)"> </button> <button class="pswp__button pswp__button--arrow--right" title="Next (arrow right)"> </button><div class="pswp__caption"><div class="pswp__caption__center"></div></div></div></div></div></body></html>
